金沙js333娱乐场二零一零年(上半年)11月软考之网络程序员中午试题答案

贰零零玖年上四个月软考在7月十七日实行。
以下为二零一零上7个月互联网程序员晚上课题参照他事他说加以考查答案:

技艺限制:沟通路由
技能主要词:VLAN 双臂路由
关键技巧:单臂路由
条件须要:一台核心路由器,一台汇集层沟通机,(可依据实际须要增减),三台PC机(可依附实际情况加多)。
症结:双手路由轻巧滋生路由器的f0/0口的干道过载,从而引起网络延迟大和单点故障时并未有冗余线路。

  1. 实验名称:Ciscoospf不总是区域,引进外部静态路由,使全网互通

  2. 试验拓扑图:

    金沙js333娱乐场 1

二零零六上五个月网络工程师晚上考题参谋答案:(200六月四月十一日考)

安插设施:

3.实施目标:1. vlan10,vlan20赢得dhcp地址

第一题:

路由器 交换机 PC机
1台 1台 3台

                   2.使vlan10,vlan20,vlan30之内互通

area0,R3,R1R2,255.255.255.0,10.0.2.2,10.0.1.2,10.0.8.2,10.0.7.2,10.0.4.2,10.0.5.2,255.255.255.128,202.115.13.1

金沙js333娱乐场 2

                  3. 运作ospf协议,使不连续区域互通

第二题:

切切实实安顿:
pc1: (vlan10)

                  4. 引进 外部路由,使全网互通,内网的其余贰个pc可以访问
pc7 

A,A,B,192.168.2.8,202.177.12.37,端口号,保留公用ip202.117.12.38
为专项使用网络计算机192.168.2.10,192.168.2.0,255.255.255.0,202.117.12.37,192.168.1.0,255.255.255.0,202.117.12.34

ip 地址 子网掩码 网关
192.168.1.1 255.255.255.0 192.168.1.254

4.配备思路:首先配置内网,然后再配备外网,最终引进外部静态路由,使全网互通

第三题:

pc2: (vlan20)

  

G,F,B,A,/ETC/HTTPD,standalone,快,100,,外号,虚拟目录,允许实行CGI程序,无法访问

ip地址 子网掩码 网关
192.168.2.1 255.255.255.0 192.168.2.254

5.试验配置与步骤: 

第四题:

pc3:(vlan30)

                         

192.168.46.1,202.134.135.98,10.0.0.1,e,b,d,设置对外访问ip地址池,允许主机202.134.135.99做客外部www财富,允许全数ip访问

ip地址 子网掩码 网关
192.168.3.1 255.255.255.0 192.168.3.254

                           # 首先配置内网,使内网互通  

第五题:

交换机SW4:

                           # 临时给pc1和pc0配置ip地址

设置f0/24为trunk情势便于传输vlan,dotlq封装24端口,设置vlan11名称叫lab01,swithport
mode access ,switchport access
vlan11,b,协议封装双方都急需使用dotlq,f0/2,将端口开启

vlan 10 vlan 20 vlan 30

                                ip addres  192.168.10.1 255.255.255.0

注:此答案为网络朋友提供参照他事他说加以调查答案,非标准答案!

沟通机配置命令:
<SW4>system-view 进入系统视图
[Huawei]sysname SW4修改沟通机名称

                                               gateway 192.168.10.254 
//pc1的ip地址

金沙js333娱乐场 3

[sw4]vlan batch 10 20 30 创造四个VLAN
[SW4]interface GigabitEthernet 0/0/4进端口
[SW4-GigabitEthernet0/0/4]port link-type access
端口情势改换为access方式
[SW4-GigabitEthernet0/0/4]port default vlan 30加入vlan
[SW4-GigabitEthernet0/0/4]quit退出
[SW4]interface GigabitEthernet 0/0/3进端口
[SW4-GigabitEthernet0/0/3]port link-type access
端口方式改动为access方式
[SW4-GigabitEthernet0/0/3]port default vlan 20加入vlan
[SW4-GigabitEthernet0/0/3]quit退出
[SW4]interface GigabitEthernet 0/0/2进端口
[SW4-GigabitEthernet0/0/2]port link-type access
端口格局改动为access方式
[金沙js333娱乐场,SW4-GigabitEthernet0/0/2]port default vlan 10加入vlan
[SW4-GigabitEthernet0/0/2]quit退出
[SW4]interface GigabitEthernet 0/0/1 进入端口0/0/1
[SW4-GigabitEthernet0/0/1]port link-type trunk 端口开启trunk格局
[SW4-GigabitEthernet0/0/1]port trunk allow-pass vlan all
允许具有vlan通过

                               ip address  192.168.20.1 255.255.255.0 

路由器悍马H21陈设命令:
<Huawei>system-view进去系统视图
[Huawei]sysname R1修改路由器名称
[R1]interface GigabitEthernet 0/0/0.1跻身子端口
[R1-GigabitEthernet0/0/0.1]dot1q termination vid
10
封装dot1q协议加入相应vlan号
[R1-GigabitEthernet0/0/0.1]ip address 192.168.1.254 24
设置子端口ip掩码
[R1-GigabitEthernet0/0/0.1]arp broadcast enable 开启接口ARP广播
[R1-GigabitEthernet0/0/0.1]quit退出
[R1]interface GigabitEthernet 0/0/0.2跻身子端口
R1-GigabitEthernet0/0/0.2]dot1q termination vid
20
封装dot1q协议出席相应vlan号
[R1-GigabitEthernet0/0/0.2]ip address 192.168.2.254
24
设置子端口ip掩码
[R1-GigabitEthernet0/0/0.2]arp broadcast enable 开启接口ARP广播
[R1-GigabitEthernet0/0/0.2]quit退出
[R1]interface GigabitEthernet 0/0/0.3进入子端口
[R1-GigabitEthernet0/0/0.3]dot1q termination vid
30
封装dot1q协议到场相应vlan号
[R1-GigabitEthernet0/0/0.3]ip address 192.168.3.254
24
安装子端口ip掩码
[R1-GigabitEthernet0/0/0.3]arp broadcast enable 开启接口ARP广播
[R1-GigabitEthernet0/0/0.3]quit//退出

                                                gateway 192.168.20.254
//pc2的ip地址 

PC3测试附图:金沙js333娱乐场 4

                              #配备sw1 ,创立vlan 10 ,vlan 20
,并且将相应的端口参与到vlan 10 ,vlan 20 

注意事项:路由器所连接端口最棒是决不有任何的配置音讯。

                                      #创办 vlan10 ,vlan20 ,vlan 30
//vlan数据库保持一致

                                        interface f0/1

                                             switchport mode access 

                                                     switchport access
vlan 10 

                                        itnerface f0/2

                                                  switchport mode
access 

                                                           switchport
access vlan 20

                                                   interface f0/3

                                                          switchport
mode trunk  //把调换机f0/3设置成了trunk,

                                         #布局sw2
,创设vlan10,vlan20,vlan 30 ,并将相应的端口参预vlan10 ,vlan20 ,vlan 30

                                            

                                                 #vlan 10 ,vlan 20
,vlan 30 

                                                    interface f0/1

                                                       switchport mode
access 

                                                           switchport
access vlan 10 

                                                        interface  f0/2

                                                               
 switchport mode access 

                                                                       
    switchport access vlan 20

                                                           interface
f0/3

                                                             switchport
mode access 

                                                               
 switchport access vlan 30 

                                      #
接下来配置三层沟通机,使vlan之间互通,

                                       #在三层调换机上创设vlan
,并且安装trunk链路,并将相应的端口参加相应的vlan,

                                          # vlan 10 ,vlan 20 ,vlan30 

                                             # 配置vlan虚拟网关 

                                               # interface vlan 10 

                                                          ip address
192.168.10. 254 255.255.255.0 

                                                  interface vlan 20 

                                                           ip address
192.168.20.254 255.255.255.0

                                                   interface vlan 30 

                                                          ip address
192.168.30.254 255.255.255.0

                                                interface  range f0/3-4 

                                                  switchport trunk
encapsulation dot1q 

                                                     switchport mode
trun k  //Cisco三层调换机必须先封装dot1q才得以设置trunk 

                                         
 #接下去先给dhcp服务器配置叁个地点,先测试vlan之间是否早就互通了

发表评论

电子邮件地址不会被公开。 必填项已用*标注