动用NPOI时IC夏普Code.SharpZipLib版本争执难点迎刃而解

系统原来引用的ICSharpCode.SharpZipLib是0.84版本的,

打开版本库下的examples文件夹

添加了2.3版本的NPOI引用后,报版本冲突错误,因为NPOI用的ICSharpCode.SharpZipLib是0.86版本的。

This is valid only for web sites – look in the bin folder of your
project and check if there is a file there called
ICSharpCode.SharpZipLib.dll.refresh.

然后打开对应的解决方案文件,尝试编译程序。发现提示缺少了dll

百度了下,貌似没有好的解决办法。

Delete it and VS will not look for new versions of the assembly when you
build the site.

 

还是得自己解决….

这些文件可以用notepad++打开,可以看到是从哪里刷新dll的 

琢磨了半天,找到四个项目文件,打开之后进行编译。最后会生成dll到solution文件夹下的Lib中

 

 

 

解决过程:

/Kentico10/LISA.Kentico10/Bin (local)

 

发表评论

电子邮件地址不会被公开。 必填项已用*标注