Eclipse版本推荐(tomcat运行项目:web、maven),eclipsemaven

1、区别

Eclipse版本推荐(tomcat运行项目:web、maven),eclipsemaven

1、区别

  Eclipse根据特性和jdk版本,从Eclipse官网可看到,分为:Neon/Oxygen/Mars/Luna/Kepler/Juno/Indigo/Helios…等等。

  Eclipse官网:

金沙js333娱乐场 1

金沙js333娱乐场 ,2、IDE推荐

  本人曾在Eclispse(以下称IDE)的版本选择中,试过Neon、Luna、Kepler、Helios等。

  Neon要求jdk版本1.8及以上,否则无法启动,使用细节不明。我的是1.6,so。。

  Kepler+Helios版本适用JDK1.6及以上,但自身集成组件不全,如有使用maven、svn、EclEmma等需安装集成。如果集成插件和使用熟悉的话,本章可以不用看咯。

  Luna版本自身插件集成较丰富,就我开发需要,只需安装svn和EclEmma工具就可以,简单许多了。

3、运行项目

  打开IDE后,通过tomcat运行项目,发现均无法访问项目,不管是web还是maven。此时需要更改tomcat服务器配置。

  第一步:停止eclipse现有的tomcat服务器。

  第二步:删除现有服务器中的项目,如果不行删除现有服务器,重建。(刚开始用无所谓,推荐重建)

  第三步:在servers下的服务器右键>>Open,在server
location中,选择默认是第一个,修改为第二个,然后保存。

  第四步:项目右键:run as >> run on
server,启动服务器,正常可在浏览器访问项目,即部署运行项目成功。

 

1、区别
Eclipse根据特性和jdk版本,从Eclipse官网可看到,分为:Neon/Oxygen/Mars/Luna/Kep…

  Eclipse根据特性和jdk版本,从Eclipse官网可看到,分为:Neon/Oxygen/Mars/Luna/Kepler/Juno/Indigo/Helios…等等。

  Eclipse官网:

金沙js333娱乐场 2

2、IDE推荐

  本人曾在Eclispse(以下称IDE)的版本选择中,试过Neon、Luna、Kepler、Helios等。

  Neon要求jdk版本1.8及以上,否则无法启动,使用细节不明。我的是1.6,so。。

  Kepler+Helios版本适用JDK1.6及以上,但自身集成组件不全,如有使用maven、svn、EclEmma等需安装集成。如果集成插件和使用熟悉的话,本章可以不用看咯。

发表评论

电子邮件地址不会被公开。 必填项已用*标注